Cisco Mobility Express: Client receives incorrect IP

After getting WLC up and running I ran into the issue with the client getting IP address from management Vlan instead of proper wireless Vlan.  I was getting the following debug output.

Static IP client associated to interface management which cannot support client subnet

Did not really make any sense but looking further into debug I’ve discovered that client would get IP from proper subnet (Vlan 70).

DHCP_REQD (7) Change state to RUN (20) last state DHCP_REQD (7)
the value of url acl preserve flag is 0 for mobile fc:e9:98:bg:dd:22 (caller pem_api.c:7659)
10.20.70.54 RUN (20) NO release MSCB
Assigning Address 10.20.70.54 to mobile
WcdbClientUpdate: IP Binding from WCDB ip_learn_type 1, add_or_delete 1
IPv4 Addr: 0:0:0:0
Static IP client associated to interface management which can support client subnet.
10.20.70.54 RUN (20) Skipping TMP rule add
apfMsRunStateDec
10.20.70.54 RUN (20) Change state to DHCP_REQD (7) last state RUN (20)
10.20.70.54 DHCP_REQD (7) NO release MSCB
apfMsRunStateInc

Then DHCP ran again and client got IP from WLC management Vlan (Vlan 53).

10.20.53.93 DHCP_REQD (7) Change state to RUN (20) last state DHCP_REQD (7)
the value of url acl preserve flag is 0 for mobile fc:e9:98:bg:dd:22 (caller pem_api.c:7659)
10.20.53.93 RUN (20) NO release MSCB
Assigning Address 10.20.53.93 to mobile

My switch port was set to trunk with native Vlan set to WLC management Vlan (Vlan53).

Eventually, after several troubleshooting exercises, I found that my WLAN native Vlan was set to wireless Vlan. Should not matter, right?

Well, it turns out it is important. As soon as I set WLAN to native Vlan to 53 to match switch trunk port configuration it started working and the client received proper IP.

Leave a reply:

Your email address will not be published.

Site Footer

Sliding Sidebar