Cisco Nexus: FEX Port in errDisable state due to BPDUGuard

While configuring trunk interface on FEX port for server connectivity I ran into an issue of the port being errDisabled due to BPDUGuard.

Port config was very simple.

interface Ethernet101/1/14
switchport mode trunk

The folowing messages appeared in the log.

Going through the rest of log I spotted these messages.

Sure enough, Vlan was pruned from VPC Peer-link causing FEX ports configured in trunk mode to go into the errDisabled state.

interface Ethernet1/1
description Peer-Link-vPC
switchport mode trunk
switchport trunk allowed vlan 1-149,151-4094
channel-group 1 mode active

Once I removed vlan 150 from server facing port with switchport allowed command FEX interface came up.

interface Ethernet101/1/14
switchport mode trunk
switchport trunk allowed vlan 10,20,30

 

Leave a reply:

Your email address will not be published.

Site Footer

Sliding Sidebar